Removed PV cover on gp800 and PV is missing, but engine runs great...?? - Page 2
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21
  1. #11
    I dream skis needforspeed's Avatar
    Join Date
    Sep 2008
    Location
    New Jersey
    Age
    49
    Posts
    526

    Re: Removed PV cover on gp800 and PV is missing, but engine runs great...??

    Quote Originally Posted by Shaun23a11en View Post
    Here's the piston. Would I be in trouble if I used this based on the condition that can be seen in the picture knowing that it did produce 135 pounds compression?Attachment 503523
    I don't think that it the piston "skirt"....the skirt is the bottom of the piston not the top with the rings?piston.gif
    If it aint broke...don't fix it!!!!

  2. #12
    Top Dog Wet Wolf's Avatar
    Join Date
    Nov 2001
    Location
    Spokane, WA
    Age
    54
    Posts
    1,598

    Re: Removed PV cover on gp800 and PV is missing, but engine runs great...??

    I would replace that piston.


    Bruce Wolford (509) 280-5444 - Pump Performance
    http://www.wetwolf.com

  3. #13
    PWCToday Newbie Shaun23a11en's Avatar
    Join Date
    Jul 2012
    Location
    Lomita, ca
    Age
    34
    Posts
    17

    Re: Removed PV cover on gp800 and PV is missing, but engine runs great...??

    yea i thought i was looking at the skirt, it was late at night lol. I am not going to replace the piston as the engine has been running fine and the compression is very good. Why would you replace it Wet Wolf?
    Last edited by Shaun23a11en; 06-16-2016 at 03:46 PM.

  4. #14
    PWCToday.com Is My Home Away From Home WFO Speedracer's Avatar
    Join Date
    Aug 2006
    Location
    Al-ugh-bam-ugh
    Posts
    26,179

    Re: Removed PV cover on gp800 and PV is missing, but engine runs great...??

    Yeah I would replace it too if I was already this far, it's not like you have to bore the cylinder or anything.
    Y'all know me, still the same O.G. but I been low-key
    hated on by most these &^$$@s with no cheese, no deals and no G's, no wheels and no keys, no boats, no snowmobiles, and no skis, mad at me cause I can finally afford to provide my family with groceries


  5. #15
    PWCToday Regular jason 650sx's Avatar
    Join Date
    Jun 2015
    Location
    nc
    Age
    43
    Posts
    65
    Blog Entries
    1

    Re: Removed PV cover on gp800 and PV is missing, but engine runs great...??

    Okay this is my first post love the site. This is what I found today when I trying to put wave eater Clips in my GP 800...Can some one please tell me where the other half of the power valve is???
    Attached Images Attached Images

  6. #16
    PWCToday Newbie
    Join Date
    Jun 2015
    Location
    Hungary
    Posts
    3

    Re: Removed PV cover on gp800 and PV is missing, but engine runs great...??

    Hi guys,

    I'm new here, but read long time ago.
    My GP800R has same problem. I found the half PV in the cylinder. The other half went out on the exhaust. (The piston damaged a little bit. I will put a new one.)
    I rebuilt the engine 40 hours ago. New crankshaft, pistons, etc. I also put a new SBT powerwalve+safety link.
    Possible the wrong PV? Maybe material defects?
    I checked the other walve, and noticed the chrome coating is damaged some places.
    I can show you later.
    What do you think about the SBT power valve?
    Maybe the OEM is better?

    Thanks in advance for your answers.
    Marci

  7. #17
    PWCToday Newbie
    Join Date
    Jun 2015
    Location
    Hungary
    Posts
    3

    Re: Removed PV cover on gp800 and PV is missing, but engine runs great...??

    Quote Originally Posted by zeppa View Post
    Hi guys,

    I'm new here, but read long time ago.
    My GP800R has same problem. I found the half PV in the cylinder. The other half went out on the exhaust. (The piston damaged a little bit. I will put a new one.)
    I rebuilt the engine 40 hours ago. New crankshaft, pistons, etc. I also put a new SBT powerwalve+safety link.
    Possible the wrong PV? Maybe material defects?
    I checked the other walve, and noticed the chrome coating is damaged some places.
    I can show you later.
    What do you think about the SBT power valve?
    Maybe the OEM is better?

    Thanks in advance for your answers.
    Marci


    Here are the pictures.Fajl_001.jpegFajl_002.jpegFajl_004.jpegFajl_003.jpegFajl_005.jpegFajl_006.jpeg
    I forgot to write:
    The bore size is STD (80.012mm). When I rebuilt the engine, I checked the distance between PV and piston. It was 0,5~0,8mm. (impossible to piston hit the PV.)

  8. #18
    PWCToday.com Is My Home Away From Home WFO Speedracer's Avatar
    Join Date
    Aug 2006
    Location
    Al-ugh-bam-ugh
    Posts
    26,179

    Re: Removed PV cover on gp800 and PV is missing, but engine runs great...??

    Quote Originally Posted by zeppa View Post
    Hi guys,

    I'm new here, but read long time ago.
    My GP800R has same problem. I found the half PV in the cylinder. The other half went out on the exhaust. (The piston damaged a little bit. I will put a new one.)
    I rebuilt the engine 40 hours ago. New crankshaft, pistons, etc. I also put a new SBT powerwalve+safety link.
    Possible the wrong PV? Maybe material defects?
    I checked the other walve, and noticed the chrome coating is damaged some places.
    I can show you later.
    What do you think about the SBT power valve?
    Maybe the OEM is better?

    Thanks in advance for your answers.
    Marci
    Basically just a sh!ttay design !
    Y'all know me, still the same O.G. but I been low-key
    hated on by most these &^$$@s with no cheese, no deals and no G's, no wheels and no keys, no boats, no snowmobiles, and no skis, mad at me cause I can finally afford to provide my family with groceries


  9. #19
    PWCToday Regular jason 650sx's Avatar
    Join Date
    Jun 2015
    Location
    nc
    Age
    43
    Posts
    65
    Blog Entries
    1

    Re: Removed PV cover on gp800 and PV is missing, but engine runs great...??

    Ya I don't think I'm going back with stock PV in rebuild. I just hope the bottom end is trash free.

  10. #20
    PWCToday Newbie
    Join Date
    Jun 2015
    Location
    Hungary
    Posts
    3

    Re: Removed PV cover on gp800 and PV is missing, but engine runs great...??

    Hi guys,

    I repaired my PWC. I designed it, and made stronger PV. This never will broken. Canít drop into the cylinders. Now working fine.
    9947239B-4740-4699-9557-D839F493A1D7.jpeg
    4133FB45-2962-4B46-8B04-810FB94F3622.jpeg

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0