need help with 1997 zxi no spark
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 8 of 8
  1. #1
    PWCToday Regular dmaxryan10's Avatar
    Join Date
    Mar 2015
    Location
    Western NC
    Posts
    110

    need help with 1997 zxi no spark

    just brought home a 750 zxi ski as a donor for my chopped flat deck x2 build. bought it in great condition but no spark. it has new coil, new plugs, new cdi, tried 2 different stators, pulled the white wire for kill switch inside e box and nothing. no spark. only thing I haven't done is changed voltage regulator or made SURE the stator and pickup was 100% working. pulled a stator off another ski...
    now all this said, is the zxi not a DC system? meaning it has no exciter on the coils? and doesn't need the stator to produce spark correct? battery should do that if I'm thinking correctly. I know zxi's are the odd balls...

    i'm lost as to why I have no spark yet. flywheel isn't loose, no sheared key, etc. should I try a different pickup for the stator? any ideas for anything else they are known for? only grey area is the stator but I can't see why it wouldn't spark even if it was bad because of it being a zxi system.. but correct me if I'm wrong.

    idk if it matters but the engine was pulled before I got it due to it getting a crank, ran out of oil. it was replaced with a silver 750 engine from something unknown to me... shouldn't make a difference I hope between big pin/small pin as long as I run zxi stator, but it could idk. just throwing that in there...

    thanks ahead of time! thing has me stumped!
    Last edited by dmaxryan10; 06-04-2016 at 12:50 AM.
    js550 with 650 swap custom wrap
    x2 750 swap flat deck
    01 superjet stock


  2. #2
    PWCToday Regular dmaxryan10's Avatar
    Join Date
    Mar 2015
    Location
    Western NC
    Posts
    110

    Re: need help with 1997 zxi no spark

    we also got in there and fixed the oil and temp lights that would not come one when first powered up, was bad connection in the e box. went through all connections after I saw that happening and still nothing...

    many main questions are
    1) does the zxi need a working stator to produce spark? should just need a pickup correct?

    2) does it matter what engine was put in it as long as I'm running zxi stator?
    Last edited by dmaxryan10; 06-04-2016 at 12:58 AM.
    js550 with 650 swap custom wrap
    x2 750 swap flat deck
    01 superjet stock


  3. #3
    PWCToday Regular dmaxryan10's Avatar
    Join Date
    Mar 2015
    Location
    Western NC
    Posts
    110

    Re: need help with 1997 zxi no spark

    I'll also say I ohmed the pickup out and got 576... seems to check out but ohming one doesn't always mean anything.
    I tried the "bump the starter trick" and watch for a single spark right at the beginning and right at the end but nothing, it's completely dead of any spark. idk where to go next. any help wil be greatly appreciated as this is the last hurdle before completing the x2 beside a little more glasswork. engine is still in the zxi as I'm wondering if it's worth pulling or not.
    Last edited by dmaxryan10; 06-04-2016 at 01:13 AM.
    js550 with 650 swap custom wrap
    x2 750 swap flat deck
    01 superjet stock


  4. #4
    PWCToday Regular dmaxryan10's Avatar
    Join Date
    Mar 2015
    Location
    Western NC
    Posts
    110

    Re: need help with 1997 zxi no spark

    anyone? I'd like to get this thing going.
    js550 with 650 swap custom wrap
    x2 750 swap flat deck
    01 superjet stock


  5. #5
    PWCToday.com Is My Home Away From Home
    Join Date
    Aug 2011
    Location
    Austin, Texas, USA
    Age
    55
    Posts
    14,009

    Re: need help with 1997 zxi no spark

    Quote Originally Posted by dmaxryan10 View Post
    we also got in there and fixed the oil and temp lights that would not come one when first powered up, was bad connection in the e box. went through all connections after I saw that happening and still nothing...

    many main questions are
    1) does the zxi need a working stator to produce spark? should just need a pickup correct?

    2) does it matter what engine was put in it as long as I'm running zxi stator?
    If you have working warning lights then that answers one of my big questions -- did you do something with the ignition switch? As for a working stator, it has two components: charging coil and ignition coil. For purposes of producing spark we care very little about the charging coil and we should focus on the ignition coil. Since you have gotten good resistance values for it then it is very likely to be good but you should do the cranking test. See what voltage you obtain from the coil during cranking. The procedure is not in the shop manuals but it's probably around 18 volts AC.

    It definitely matters what engine you put in. If the flywheel is not the right size/type for the pickup coil then it's not going to generate the signal for the CDI to fire. The magnets might not be in the correct position. If you put in a 3 cylinder engine with a 2 cylinder CDI then if it runs at all it's going to be quite rough. As for the 750 Kawasaki engine ignition modules, the ones you will run across are ones for the 750zxi, 750sx small pin, 750sx/750sxi/750 sxi pro big bin, and (I think) the one for the 750ss. I'm unsure of the interchangeability between the stator and flywheel combinations but the CDIs will have slightly different timing curves and you won't achieve the best performance without them matching.
    Riding mostly Lake Austin

    1984 JS440 -- 1989 650sx -- 1991 X2 -- 1992 750sx -- 1995 900zxi (qty 2) -- 1995 X2

    Quote Originally Posted by cujo View Post
    God intended PWC to be two strokes, as well as dirt bikes, snowmobiles, and chain saws....

  6. #6
    PWCToday.com Is My Home Away From Home hyosung's Avatar
    Join Date
    Aug 2010
    Location
    Australia
    Posts
    8,471

    Re: need help with 1997 zxi no spark

    as Paul has posted "and' has been covered many times in the past there are a many different electrical systems on Kawasaki engines , either will not work with components from another type , spend some time searching for compatibility of the components you have there ( go by part # for the model your using) , also as i have posted before > if you use incompatible Kawasaki electrical components you will fvck your shyt up and chase your tail trying to get shyt working properly .. "" dont try to mix and match any Kawasaki electrics"""
    Last edited by hyosung; 06-04-2016 at 12:52 PM.
    http://www.pwctoday.com/showthread.php?t=425767

    modded X2 650

    900 powered custom 650 sx .

    Jerry Rigging is my specialty .....



    if i did like everyone else and copied everything i needed or wanted i would save lots of time and money.

  7. #7
    PWCToday Regular dmaxryan10's Avatar
    Join Date
    Mar 2015
    Location
    Western NC
    Posts
    110

    Re: need help with 1997 zxi no spark

    I bought the ski with the engine already swapped so I'm gonna have to dig to find what exactly it is out of, he did say it has run before and he rode it 2 hrs not long ago in one trip but it wouldn't start back after shutoff, so he let it sit. went to start it and no fire and I bought it in this state. it has 750zxi electronics on it now as far as cdi, coil, etc etc. the ski is still complete. only question was if they pulled the zxi flywheel off when they did the swap. I'll have to check, stator is off a zxi as well., just not sure what engine it is out of. I will test the ignition coil while cranking as I haven't done that yet. the voltage regulator and stator are the only things not brand new in the eectronics so it has to be something there, or something stupid simple I haven't found yet...
    Last edited by dmaxryan10; 06-04-2016 at 01:49 PM.
    js550 with 650 swap custom wrap
    x2 750 swap flat deck
    01 superjet stock


  8. #8
    PWCToday Regular dmaxryan10's Avatar
    Join Date
    Mar 2015
    Location
    Western NC
    Posts
    110

    Re: need help with 1997 zxi no spark

    it was the pickup... tested fine when ohm'd but wouldn't pick anything up, swapped the pickup out from a known working one and runs like a raped ape. thanks everyone. got almost all the foaming done on the build, about ready to start glassing and smoothing. turning out awesome.
    js550 with 650 swap custom wrap
    x2 750 swap flat deck
    01 superjet stock


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0