pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 2 of 2
  1. #1
    PWCToday Newbie windycitydj's Avatar
    Join Date
    Jul 2010
    Location
    Chicago
    Posts
    13

    1999 Polaris SLX 1050 - HELP!

    I have a 1999 Polaris SLX 1050. Was running awesome last year and up until last week. New Battery, plugs and fuel.

    Was running on the lake last week. I would throttle and it would rev high and not move more than 5 mph. Had light smoke out the exhaust. This happened for 20 minutes then it would throttle to about 10 MPH with the throttle wide open. Took it home, cleaned and tightened plugs, added new fuel and hit the lake yesterday. Same thing. Starts fine, throttles to about 5-10 mph.

    Need some help. I have the carb out and bought a rebuild kit. Changing all grey fuel lines to black. Not sure if this will help.

    Im in the Chicago area (Lombard). If anyone here is local I would like to pay an expert to fix this. Let me know and thank you.

  2. #2
    PWCToday.com Is My Home Away From Home bills86e's Avatar
    Join Date
    May 2008
    Location
    florida
    Posts
    3,257

    Re: 1999 Polaris SLX 1050 - HELP!

    Wear ring in the jet pump is shot. Never ride a ski if its not 100%. JMO

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0