550 Crank Question
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 6 of 6
  1. #1
    PWCToday Regular Groundfox98's Avatar
    Join Date
    Jul 2015
    Location
    Orange
    Age
    24
    Posts
    99

    550 Crank Question

    On my 550 that I bought I noticed it was missing the plate on the pump side of the crank that has four bolts and bolts to the side of the case. I haven't been able to get the motor started and was wondering if t was absolutely necessary to have that piece on or if I can live without it and move on to my next issue.


    Sent from my iPhone using Tapatalk

  2. #2
    PWCToday.com Is My Home Away From Home
    Join Date
    Dec 2014
    Location
    Lancaster
    Posts
    2,119
    Blog Entries
    2

    Re: 550 Crank Question

    Post pic of area in question to see if it matters, you probably do not have a full circle bottom end,

  3. #3
    PWCToday Regular Groundfox98's Avatar
    Join Date
    Jul 2015
    Location
    Orange
    Age
    24
    Posts
    99

    Re: 550 Crank Question

    I don't have a picture of my exact motor at the moment, I can take one when j get home I a Few hours. But

    It's the part between the crank rotor and the case


    Sent from my iPhone using Tapatalk

  4. #4
    PWCToday Regular Groundfox98's Avatar
    Join Date
    Jul 2015
    Location
    Orange
    Age
    24
    Posts
    99

    Re: 550 Crank Question

    My case has the four holes but doesn't have the plate that my other ski has.


    Sent from my iPhone using Tapatalk

  5. #5
    PWCToday.com Is My Home Away From Home
    Join Date
    Dec 2014
    Location
    Lancaster
    Posts
    2,119
    Blog Entries
    2

    Re: 550 Crank Question

    A pic will verify, if it has a bolt holding coupler on its a full circle bottom end, and unless modified would require seal carrier

  6. #6
    PWCToday Regular Groundfox98's Avatar
    Join Date
    Jul 2015
    Location
    Orange
    Age
    24
    Posts
    99

    Re: 550 Crank Question

    So could that be why I've been so unsuccessful at getting her started? It has 135/135 compression and a primer. It will turn over and sputter but it won't start.


    Sent from my iPhone using Tapatalk

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0