My X-2 Gen2 build - Page 30
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Page 30 of 30 FirstFirst ... 20282930
Results 291 to 298 of 298
  1. #291
    Top Dog aggrovated's Avatar
    Join Date
    Jul 2008
    Location
    Frozen Tundra, MN
    Posts
    1,773

    Re: My X-2 Gen2 build

    This is what happens when you use an after market bed plate and the coupler was loose against the driveshaft by 1/2 " OEM bedplates from now on.


  2. #292
    Top Dog octane114's Avatar
    Join Date
    Mar 2009
    Location
    charleston,sc
    Age
    39
    Posts
    1,356

    Re: My X-2 Gen2 build

    That’s awful! What engine plate are you using? Did it mess up the hull? or just stall the ski?
    it is what it is . it's all good

  3. #293
    Top Dog aggrovated's Avatar
    Join Date
    Jul 2008
    Location
    Frozen Tundra, MN
    Posts
    1,773

    Re: My X-2 Gen2 build

    I have no idea what kind of bedplate it is, I stupidly got it off FB. I only stalled the ski, I even held on going at wat! No other damage then the coupler, driveshaft and bearing.. I lucked out!


    on another note: looking to buy a new coupler setup... what happened to ADA Racing website?
    Last edited by aggrovated; 05-17-2021 at 08:22 PM.

  4. #294
    PWCToday Guru Frikinski's Avatar
    Join Date
    May 2011
    Location
    Central Valley, California
    Age
    42
    Posts
    338

    Re: My X-2 Gen2 build

    Quote Originally Posted by aggrovated View Post
    This is what happens when you use an after market bed plate and the coupler was loose against the driveshaft by 1/2 " OEM bedplates from now on.


    itís not the bed plate, itís the fact that your drive shaft was a half inch spaced away from the coupler. A half inch is a lot. You should have put a rubber piece of material in the impeller to space the drive shaft forward so that the coupler is up against the biscuit. Also, I am assuming you installed it this way so you probably didnít check the space alignment around the couplers to see that they were equally spaced or if the engine required shims.

    By the way, that should be a rad dudes plate. I initially bought this plate for my 1100 setup but felt the plate needed to be stiffer for an 1100. Iíd imagine an 800 would work just fine.
    "Information is not knowledge" - Albert Einstein.

  5. #295
    Top Dog aggrovated's Avatar
    Join Date
    Jul 2008
    Location
    Frozen Tundra, MN
    Posts
    1,773

    Re: My X-2 Gen2 build

    of course I checked alignment...that's the first thing I did. but you are right about the spacer... It was my error...I just didn't check that thoroughly... I now know the importance of that. luckily it was just a $500 mistake.

  6. #296

    Re: My X-2 Gen2 build

    Curious about the RD 1100 bed plate with a 800. Did you have to modify the plate for case bolts or stator cover? Pic of the front would be much appreciated!

  7. #297
    Top Dog aggrovated's Avatar
    Join Date
    Jul 2008
    Location
    Frozen Tundra, MN
    Posts
    1,773

    Re: My X-2 Gen2 build

    I did not do any modification...however, the mount holes seemed to be reamed out somewhat. The fitment onto the mounts was super tight. (the opposite direction of the reamed portion of the holes.) towards the inside... not outside... if that makes sense.



    Last edited by aggrovated; 05-18-2021 at 01:13 PM.

  8. #298

    Re: My X-2 Gen2 build

    Thanks !!

Page 30 of 30 FirstFirst ... 20282930

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0