SXR 800 starter relay
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 6 of 6
  1. #1
    PWCToday Newbie
    Join Date
    Aug 2013
    Location
    Florida East Coast
    Posts
    2

    SXR 800 starter relay

    Hello,
    Hoping for a little help. I have been experiencing an intermittent issue with my 2007 Kawa 800 SXR. Sometimes when I go to start it I am only getting a clicking sound coming from the electric box. I'm assuming this is the sound of the starter relay. The engine will not turn over - just the clicking upon hitting the start button. I did some troubleshooting. When this happens and the start button is depressed there is no power to the starter side of the relay only to the battery side. The battery is brand new and all terminals are clean and tight from the battery to the relay. I was able to "jump" the terminals on the relay using a screwdriver and the starter spins the engine perfectly but it does not fire. I am guessing that bypassing the start button and jumping the starter directly like this it leaves the ignition system de-energized so no fire. After fussing with it for a few minutes and repeatedly pushing the start button the machine usually cranks and runs with start button. Like I said this is intermittent. The ski is completely stock and in super clean conditions (low hours).

    So - starter relay going bad? Start/Stop switch going bad? Something inside the EC box loose? Or something else completely. I do have the service manual and they do show how to test these components but my concern is they will test ok unless I can catch it not working again.

    Advice is welcomed!
    Thanks
    Todd

  2. #2
    PWCToday Newbie
    Join Date
    Aug 2017
    Location
    Nyc
    Age
    42
    Posts
    3

    Re: SXR 800 starter relay

    Did you ever figure it out? I have the same problem

  3. #3
    PWCToday Regular
    Join Date
    Aug 2018
    Location
    all up in her
    Age
    86
    Posts
    94

    Re: SXR 800 starter relay

    As titled, it's the starter relay. Could be a loose connection along the way. If you jump it, and it works, 95.0001113345628485868768% chance it's the relay. But, hey, I just ride the things.
    I'm a baaaaaaaaaaad boy

  4. #4
    PWCToday Newbie
    Join Date
    Aug 2017
    Location
    Nyc
    Age
    42
    Posts
    3

    Re: SXR 800 starter relay

    Did replacing the relay fix your problem?

  5. #5
    PWCToday Regular
    Join Date
    Aug 2018
    Location
    all up in her
    Age
    86
    Posts
    94

    Re: SXR 800 starter relay

    I am not the op.
    I'm a baaaaaaaaaaad boy

  6. #6
    PWCToday Regular rog_i's Avatar
    Join Date
    Dec 2012
    Location
    A small place called Swakopmund Namibia
    Posts
    85

    Re: SXR 800 starter relay

    Ive had it before, installed a new relay and it was sorted.


    Sent from my iPhone using Tapatalk

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0