pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 5 of 5
  1. #1
    PWCToday Newbie rgj1952's Avatar
    Join Date
    Jun 2013
    Location
    san antonio
    Posts
    3

    Polaris MSX150 over revving at start

    Have a 2004 MSX 150 and the throttle cable snapped. Ever since I replaced the cable, the engine revs to the max rpm when started. The cable works fine as apparently so does the throttle body. I'm guessing it's one of electronic control modules, but it's strange that it would happen the same time the cable broke. I've not seen anyone post this problem before. I'm pretty sure the cable was installed correctly. Have taken it to three different shops in the San Antonio area and no one seems to be able to figure it out. And they really didn't even want to try. Anyone know of a shop in the San Antonio area that can work on the Polaris electronics? Last question, is there a list of dealers that originally sold the Polaris? Any info would be appreciated.
    Last edited by rgj1952; 06-17-2013 at 07:30 PM.

  2. #2
    I dream skis
    Join Date
    Jun 2002
    Location
    Seattle WA
    Posts
    607

    Re: Polaris MSX150 over revving at start

    The MSX should be stared with the lever in Reverse.
    Look on the GH forum for more info!
    Please visit www.weberpower.com

  3. #3
    PWCToday Newbie rgj1952's Avatar
    Join Date
    Jun 2013
    Location
    san antonio
    Posts
    3

    Re: Polaris MSX150 over revving at start

    Thanks for the reply. When I start it in reverse, it only revs up to what it's supposed to in reverse. But as soon as I put it in forward, it throttles up to the max. Maybe the cable is not on right, but a couple of shops that did look at it, think the cable and spring are good. So....

    What's the GH forum?
    Last edited by rgj1952; 06-21-2013 at 06:42 PM. Reason: add

  4. #4
    PWCToday.com Is My Home Away From Home delagem's Avatar
    Join Date
    Nov 2004
    Location
    Homer, NY
    Age
    52
    Posts
    2,698

    Re: Polaris MSX150 over revving at start

    You're saying that it's revving very high when started out of the water, right?

    What Randy's saying is the MSX150 will rev to the moon when started without a load on the pump; for example, out of the water, on the trailer. It's fine when started in the water, right?

    If so, nothing is wrong. Just always start it with the reverse lever pulled, when starting it out of the water.

    Most of the Polaris people moved over to www.greenhulk.net 7 years ago; you'll find a lot more Polaris people and resources over there.
    '58 Vincent Amanda Water Scooter, 0rpm, 0mph

    '84 SurfJet 236ss Freestyle, 5950rpm, 24.6 mph

    '91 Jetmate! SX-R 800,GroupK carbs,R&D 26cc head,R&D ProLok F/A, Coffman Rocket Pipe,Impros 13-20,76mm nozzle: 6630rpm and 38.1mph GPS

    '92 SL650/750, dry pipe,extended pump,trim,HotSeat Waterbox: 6320rpm, 50.1 mph

    '00 SLX,Tau Ceti F/A's,NuJet prop: 6670rpm, 63.1 mph

    '03 Octane, Watcon 2318 CDI

    '04 MSX140,Impros stage 2 Powertune 14/23,WetWolf,6deg wedge: 6750rpm, 60.5 mph

  5. #5
    PWCToday Newbie rgj1952's Avatar
    Join Date
    Jun 2013
    Location
    san antonio
    Posts
    3

    Re: Polaris MSX150 over revving at start

    Thanks for the info. I haven't tried it in the water as I didn't know there would be a difference and didn't want to end up 100 yards onshore. again, Thanks for the info and I'll put it in the water while still on the trailer and see what happens.
    Last edited by rgj1952; 06-21-2013 at 08:57 PM. Reason: add

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0