pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» wallpapers

Results 1 to 6 of 6
  1. #1
    PWCToday Newbie
    Join Date
    Aug 2010
    Location
    Southwest MN
    Age
    34
    Posts
    34

    how to run flush on a slt

    Hi, I am working on a 96 slt 700. It had electrical problems and now I have running and would like to run it on the hose so I can check charging system and a few other things. I just dont know how a polaris cooling system is to be hooked up. Any help would be great.

  2. #2
    Top Dog Wet Wolf's Avatar
    Join Date
    Nov 2001
    Location
    Spokane, WA
    Age
    49
    Posts
    1,792

    Re: how to run flush on a slt

    You can run the engine for 20-30 seconds without being on a flush hose, more than enough time to check the charging system.


    Bruce Wolford (509) 280-5444 - Pump Performance
    http://www.wetwolf.com

    Any electricians out there? Check out this new tool... http://www.d-reamer.com

  3. #3
    PWCToday Regular
    Join Date
    May 2009
    Location
    Rock Spring, GA
    Age
    34
    Posts
    108

    Re: how to run flush on a slt

    If you need longer than 20-30 secs I made a flush kit for an old sl750 I had from parts at Home Depot. On the water rail there is a brass fitting opposite the overheat sensor. Remove this and get the appropriate sized brass barb fitting to go in there (can't remember the size...1/2"??). I used about 10 inches of clear high pressure hose (I want to say it was 5/8" or 1/2") and a female garden hose barb on the other end. I think I spent around 8 or 9 bucks, but DO NOT ride it with the flush kit on...I nearly flooded the hull last time I did that because the hose came off while I was riding. Just take the brass fitting from the water rail with you to be sure you get the correct threading and you should be good to go.
    Hope this helps.

  4. #4
    PWCToday Newbie
    Join Date
    Aug 2010
    Location
    Southwest MN
    Age
    34
    Posts
    34

    Re: how to run flush on a slt

    Thanks, I was pretty sure that was the fitting, but was not sure if it was or not.

  5. #5
    I dream skis
    Join Date
    Oct 2006
    Location
    cleveland
    Posts
    512

    Re: how to run flush on a slt

    Do not run the engine for long with the jet pump hooked up. You will damage the thru hull seal.

    There's no water to cool the seals.

  6. #6
    Frequent Poster Keith447's Avatar
    Join Date
    Aug 2007
    Location
    Toronto, Ontario, Canada
    Posts
    168

    Re: how to run flush on a slt

    Two minutes MAX run time on the hose, to prevent the drive shaft bushings from overheating.

    If you want to run longer, take the jet pump and drive shaft out first.

    Also, if the thermostat has been removed then you must clamp off the water exit hose to force the reverse flush water flow to actually flow backwards through the engine.

    It is common for the MAG cylinder to not be properly cooled while running on the garden hose, so keep an eye on the cylinder temperatures.

    More info, follow the link below
    Click here for more help ==> www.greenhulk.net


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0