pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» wallpapers

Results 1 to 2 of 2
  1. #1
    PWCToday Newbie
    Join Date
    Jun 2010
    Location
    San Angelo, TX
    Age
    33
    Posts
    15

    New to Polaris and having engine troubles

    I just got my first Polaris pwc the other day on a trade, it is a 97 sl 1050. I just recently bought 2 seadoo's and totally rebuilt them, actually took them out yesterday for the first time and they ran great. Well im fixing to leave for 2 weeks for work and want to see if I can get the problem diagnosed with the Polaris. First of all it starts right up but will hardly rev up anymore than an idle. It sounds like it is missing. I pulled the plugs and they are wet and i checked all the plugs for spark and spark is good. The guy I got it from replaced the stator on it but i did not get the part number off him. I was looking today at the cdi box and it shows it is still the orignal box that came with the ski (part# 4060170). I emailed the guy about the part number for the stator and he has not gotten back with me. I guess my question is if he put an updated stator in does it have to the updated cdi? Also is there anything else i should check to see why the ski wont rev up and sound like its missing? thanks
    Last edited by mike2; 09-25-2010 at 07:46 PM.

  2. #2
    PWCToday.com Is My Home Away From Home delagem's Avatar
    Join Date
    Nov 2004
    Location
    Homer, NY
    Age
    48
    Posts
    2,416

    Re: New to Polaris and having engine troubles

    There's a ton of info and a bunch of great guys over on greenhulk.net that can help you with your 1050. I personally don't know much except they were part of those years that had the run of bad PVL ignitions. Here's some light reading for you....

    http://polarispwcknowledge.shorturl....ic-engined-pwc
    '58 Vincent Amanda Water Scooter, 0rpm, 0mph

    '84 SurfJet 236ss Freestyle, 5950rpm, 24.6 mph

    '91 Jetmate! SX-R 800,GroupK carbs,R&D 26cc head,R&D ProLok F/A, Coffman Rocket Pipe,Impros 13-20,76mm nozzle: 6630rpm and 38.1mph GPS

    '92 SL650/750, dry pipe,extended pump,trim,HotSeat Waterbox: 6320rpm, 50.1 mph

    '00 SLX,Tau Ceti F/A's,NuJet prop: 6670rpm, 63.1 mph

    '03 Octane, Watcon 2318 CDI

    '04 MSX140,Impros stage 2 Powertune 14/23,WetWolf,6deg wedge: 6750rpm, 60.5 mph

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0