pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 2 of 2
  1. #1
    Frequent Poster SeaNile's Avatar
    Join Date
    May 2008
    Location
    West Chester, PA
    Age
    44
    Posts
    194

    Ultra 150 not reaching full RPM's, only 3100rpm

    2000 Ultra which I just bought was pretty much completely redone and has not been run in about a year. I changed plugs, added fresh gas and even tried carb cleaner as well as running with flame arrestor off to see if more air would help.....here is the issue. I bit of a hard start when cold but once running will idle fine. In the driveway, hooked up to water it will turn about 8000rpms but once I put it in the water and try to use it I can only get 3100 maybe 3200rpms at best.

    It's not the overheating sensor as I unplugged it and it made no difference, carb cleaner did not work, choke is off when running and no matter what I can thin of or do I only get 3100rpm. Once on the trailer and out of water it will reach 8000rpms.

    What could be the issue? Fuel problem? Bad/clogged carb or fuel pump?? I do think all 3 cylinders are firing...compression is 116, 120, 120

    Thanks.

    --JK
    Last edited by SeaNile; 08-19-2009 at 10:34 PM.

  2. #2
    Kawasaki Master Tech PWCToday Newbie
    Join Date
    Jan 2002
    Location
    Maryland..home of the Chesapeake Bay
    Age
    48
    Posts
    38

    Re: Ultra 150 not reaching full RPM's, only 3100rpm

    Ski is at our shop..
    Thanks, Steve
    Skiworx Watercraft Performance
    410-766-7900
    Ultra150.com Administrator/Owner



    Please Visit Skiworx.com
    email steve@skiworx.com
    Visit Ultra150.com

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0