pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» wallpapers

Results 1 to 6 of 6
  1. #1
    PWCToday Newbie
    Join Date
    Aug 2007
    Location
    florida
    Posts
    15

    1100 stx di won't idle, help

    I got my 2000 ski working finally after 2 years and it will not idle. If I hold the throttle it will run between 300-6500 rpm's, but as soon as I let off the throttle it dies. I put new plugs in it and a newer fuel pump from an 03 model, help??

  2. #2
    PWCToday Newbie
    Join Date
    Jul 2009
    Location
    indiana
    Posts
    13

    Re: 1100 stx di won't idle, help

    Have you tried adjusting your low speed screw?

  3. #3
    PWCToday Newbie
    Join Date
    Aug 2007
    Location
    florida
    Posts
    15

    Re: 1100 stx di won't idle, help

    No I haven't. Is that the screw at the base of the box?

  4. #4
    Top Dog kawiski's Avatar
    Join Date
    Jul 2004
    Location
    All Over
    Posts
    1,208

    Re: 1100 stx di won't idle, help

    Quote Originally Posted by doczuki View Post
    Have you tried adjusting your low speed screw?
    DI stands for Direct Injection - all computer controlled electronic fuel injection system on this 3-cyl 1100 STX. You will not find the low speed screw on this engine.

    Poor idling means usually you are running on either one or two cylinders only. You need a new ECU, aka EMM.
    Most ski problems are caused by the loose NUT connecting the handle bar to the seat.

  5. #5
    PWCToday Newbie
    Join Date
    Aug 2007
    Location
    florida
    Posts
    15

    Re: 1100 stx di won't idle, help

    I just had the EMM done by dfi and a new fuel pump. It has been sitting for awhile, so maybe bad gas.

  6. #6
    Top Dog kawiski's Avatar
    Join Date
    Jul 2004
    Location
    All Over
    Posts
    1,208

    Re: 1100 stx di won't idle, help

    Quote Originally Posted by creativ43 View Post
    I just had the EMM done by dfi and a new fuel pump. It has been sitting for awhile, so maybe bad gas.
    DFI rebuilt EMM may have been bad from the beginning or has gone bad AGAIN. EMM goes bad for a reason - the number one reason is overheating due to insufficient cooling water flow. EMM is extremely sensitive to the heat. That's why it is watercooled, which is extremely rare. You also must understand that's why there are two cooling water circuits on DI 1100 STX, one for engine and another for EMM via stator. If DFI guys did not properly program the fuel flow parameters (injector coefficients) into the rebuilt EMM, your engine would run either too lean or too rich causing idling problem. Time to knock on the DFI door.

    Fuel pump is either working or not working on DI skis. There is nothing in between and the bad ilding problem has nothing to do with the fuel pump. If someone suggested you replacing the pump, you'd better go knock on his/her door as well.

    Bad gas possiblity is easy to figure it out. Just replace with fresh one and see.
    Last edited by kawiski; 08-12-2009 at 02:57 PM.
    Most ski problems are caused by the loose NUT connecting the handle bar to the seat.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0