pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» wallpapers

Results 1 to 4 of 4
  1. #1
    PWCToday Newbie
    Join Date
    Jul 2009
    Location
    Paterson NJ
    Age
    28
    Posts
    5

    Angry Engine wont start without Starting Fluid..? HELP

    i'm having a little problem with my ski, it would not start without giving it a shot of starting fluid, this is a new motor. i changed the spark plugs, the spark plug wires already checked the pressure of all four pistons, already checked the injectors and the are all fine, the fuel filter is pumping the right fuel. "but the engine would not start without a shot of staring fluid sometimes it wont even start ooh by the way i already checked the entire wire harness so can some one please tell me what can be causing this problem. 2005 Kawasaki STX 15F.

  2. #2
    I dream skis hilomikey's Avatar
    Join Date
    Jun 2005
    Location
    HIlo Hawaii
    Posts
    600

    Re: Engine wont start without Starting Fluid..? HELP

    Do you use ethanol blended gas? Has the ski sat for a long time? sometimes the gas separates and has a hard time getting through the pump.
    Mike

    02 900 STX
    07 Ultra 250 (the Ali'i of Hilo Bay, Baby)

  3. #3
    PWCToday Newbie
    Join Date
    Jul 2009
    Location
    Paterson NJ
    Age
    28
    Posts
    5

    Re: Engine wont start without Starting Fluid..? HELP

    Today what i did was pumped out the entire gas tank and filled it up with super to see if that could solve the problem but no, same thing over and over.... I also put a little bottle of fuel injector cleaner..

  4. #4
    PWCToday Newbie
    Join Date
    Jul 2010
    Location
    Florida
    Posts
    24

    Re: Engine wont start without Starting Fluid..? HELP

    Quote Originally Posted by Grimmi03 View Post
    i'm having a little problem with my ski, it would not start without giving it a shot of starting fluid, this is a new motor. i changed the spark plugs, the spark plug wires already checked the pressure of all four pistons, already checked the injectors and the are all fine, the fuel filter is pumping the right fuel. "but the engine would not start without a shot of staring fluid sometimes it wont even start ooh by the way i already checked the entire wire harness so can some one please tell me what can be causing this problem. 2005 Kawasaki STX 15F.
    Do you spray the air filter with the starting fluid??

    I also have this kind of problem

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0