pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 5 of 5
  1. #1
    PWCToday Regular CaptainOverSpray's Avatar
    Join Date
    Jul 2007
    Location
    Milwaukee
    Age
    39
    Posts
    143

    Help Loss of RPM

    I recently had my carbs, prop, and pump done and now I am seeing 6300 RPM on my ultra 150. I am looking for some ideas on how to increase the RPM back to where it should be around 7000 RPM.

    Not sure if it is the prop that is to tall or an issue with the carbs.

  2. #2
    Kawasaki Master Tech PWCToday Newbie
    Join Date
    Jan 2002
    Location
    Maryland..home of the Chesapeake Bay
    Age
    48
    Posts
    38

    Re: Help Loss of RPM

    Who did the work? Did you have head work or change heads?
    Thanks, Steve
    Skiworx Watercraft Performance
    410-766-7900
    Ultra150.com Administrator/Owner



    Please Visit Skiworx.com
    email steve@skiworx.com
    Visit Ultra150.com

  3. #3
    PWCToday Regular CaptainOverSpray's Avatar
    Join Date
    Jul 2007
    Location
    Milwaukee
    Age
    39
    Posts
    143

    Re: Help Loss of RPM

    I had you do the work. You pitched my prop and blueprinted it for a stock class mod to the carbs. I am located in Milwaukee, WI and you might remember the job. I was the one the the F/A adaptors got lost somewhere in the mix. I also had you set me up with the prok F/A's.

    I was also having a low end loading issue and working with the guys over on your forum they have helped me correct that. I ended up turning out the air screw one full turn. Now it should not load up on the starting line after I clean out the motor. Still seems to be to fat when going thrue long no wake zones.

    Is there something that I can do myself to correct this or do I need to send these carbs back to you to look at? Also I am thinking about going limited with the boat now since there is more of them racing this year in our series. Would putting a head on there help with this issue? And what kind of deal can we work out on a head from you since I had to buy the three F/A adaptors at $26.00 each.

  4. #4
    PWCToday Regular CaptainOverSpray's Avatar
    Join Date
    Jul 2007
    Location
    Milwaukee
    Age
    39
    Posts
    143

    Re: Help Loss of RPM

    I did have the F/A off last night and did notice some oil on the inside of it. Would that be a sign of failing reeds and could that be causing my RPM issue?

  5. #5
    Kawasaki Master Tech PWCToday Newbie
    Join Date
    Jan 2002
    Location
    Maryland..home of the Chesapeake Bay
    Age
    48
    Posts
    38

    Re: Help Loss of RPM

    The carbs need to be reworked.. The setup we sent you is too rich for stock class.. Stock class mod is tricky because of the lack of compression.. If you where to go to limited and add a head or mill yours that would solve the carb issues however I would recommend you do a plug chop before racing/riding the ski after the heads are installed!
    Thanks, Steve
    Skiworx Watercraft Performance
    410-766-7900
    Ultra150.com Administrator/Owner



    Please Visit Skiworx.com
    email steve@skiworx.com
    Visit Ultra150.com

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0