pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23
  1. #11
    PWCToday Guru
    Join Date
    Aug 2006
    Location
    Niceville Florida's Gulf
    Age
    49
    Posts
    407

    Re: SLT 780 wont run over 4000 rpm-Hitting limiter???

    Quote Originally Posted by Keith447 View Post
    The only RPM limiter on the Polaris 1997 SLT780 is for engine overheat.

    The MFD display does not trigger the RPM limiter, it only lights the red warning lamp when the Tan colored Temp sensor wire is grounded.
    In normal operation, the temp sensor wire is an open circuit.

    To disable the RPM limiter find the Tan wire running from the Temp sensor to the electrical box, and disconnect it inside the electrical box.

    If that doesn't fix it, then disconnect the Tan wire that goes into the CDI module.

    If it is still RPM limiting, the CDI module may be bad.

    Make sure the correct resistor type spark plugs are installed. Non-resistor plugs can cause weird ignition problems.

    Also make 100% sure the black ground wire from the electrical box to the stator is actually grounded to the engine block. Disconnect the battery negative wires, separate them, and then check ohms from each to the engine block, and to the electrical box black wires.

    And make sure the CDI ground is really solid.

    Have you checked that all ignition coil and stator coil ohms are in spec?
    Thanks for this info here mate!.
    I havent ohm'd out coil or stator as yet, but will do this. I like all your info here so i'll work through it all and see what I come up with. It will be interesting to see what it is. Good to find someone who knows polaris's.Thanks. 98% of people(-mechanics) dont wont to know about them?

  2. #12
    PWCToday Newbie
    Join Date
    Aug 2010
    Location
    Florida
    Age
    37
    Posts
    2

    Re: SLT 780 wont run over 4000 rpm-Hitting limiter???

    Hello just to let you know I had the same kind of problem with my 1996 Polaris 780 sl I had a problem with the fuel guage and speedometer making my jetski go into limp mode because neither would work right so I just pulled out the fuse for the mfd digital guage and my jetski ran perfectly but you wont have a digital guage thats all it fixed mine and ran like a clock at over 52 mph I know this is an old post but maybe it can help someone save their jetski and not lose out on the fun they could be having thanks jut dont forget to check your oil everytime you ride!! I also recommend using premix or mixing your oil yourself it just fixed a jetski I own which is a Poalris 1050 sltx which was having an overheating issue due to a bad oil injection system which almost fried my engine but now I am riding over 58 mph on my 1996 sltx 1050 hope this helps someone out also!!! Have a nice day everyone!!
    Josh

  3. #13
    Frequent Poster SeaBR Ryder's Avatar
    Join Date
    Jun 2009
    Location
    Long Island, NY
    Age
    38
    Posts
    178

    Re: SLT 780 wont run over 4000 rpm-Hitting limiter???

    Also try Resetting the MFD to clear any past codes And recalibrate it self

    MFD reset;
    You may need to first touch the Mode button to wake up the MFD

    Press and hold the MODE and SET buttons until CAL 0000 displays. The CAL display will usually show after 4 seconds
    Release both buttons?

    Press and hold the SET key
    While continuing to hold the SET key and within 2 seconds of pressing the SET key, press and hold the MODE key
    Don't release either key until the MFD shuts down (about ten seconds).
    After the MFD has shut itself down, press the mode key to turn the MFD on
    Depress the MODE key repeatedly until voltage is displayed and verify that the voltage reading has been restored.
    '97 GP 760
    '01 CBR 929RR

    www.JetSport.net

  4. #14
    PWCToday Newbie
    Join Date
    Oct 2015
    Location
    Saskatoon
    Posts
    7

    Re: SLT 780 wont run over 4000 rpm-Hitting limiter???

    Hello Did you find the problem ..I have a 97 slt 780 doing the exact same thing thx????

  5. #15
    PWCToday Newbie
    Join Date
    Oct 2015
    Location
    Saskatoon
    Posts
    7

    Re: SLT 780 wont run over 4000 rpm-Hitting limiter???

    hi where am I looking for these 0000 on the mfd thx

  6. #16
    PWCToday Newbie
    Join Date
    Oct 2015
    Location
    Saskatoon
    Posts
    7

    Re: SLT 780 wont run over 4000 rpm-Hitting limiter???

    Cool I'll try all this

  7. #17
    PWCToday Regular
    Join Date
    Jun 2006
    Location
    Norman
    Age
    34
    Posts
    67

    Re: SLT 780 wont run over 4000 rpm-Hitting limiter???

    I did fix mine and I sold it. However, the stator went out on it about 2 weeks after I sold it. I replaced two stators, the coils and a cdi. I want to say the coil was my problem. I haven't touched a polaris in 5 years since I moved over to yamaha, so I'm doing my best to recall how I fixed it.

  8. #18
    PWCToday Newbie
    Join Date
    Oct 2015
    Location
    Saskatoon
    Posts
    7

    Re: SLT 780 wont run over 4000 rpm-Hitting limiter???

    Quote Originally Posted by fozziez28 View Post
    I did fix mine and I sold it. However, the stator went out on it about 2 weeks after I sold it. I replaced two stators, the coils and a cdi. I want to say the coil was my problem. I haven't touched a polaris in 5 years since I moved over to yamaha, so I'm doing my best to recall how I fixed it.
    Ok thx I will look into that thx

  9. #19
    PWCToday.com Is My Home Away From Home Myself's Avatar
    Join Date
    Jun 2006
    Location
    Arkansas
    Age
    41
    Posts
    4,697

    Re: SLT 780 wont run over 4000 rpm-Hitting limiter???

    On the Polaris machines, a bad stator can cause high RPM problems. Ohms test when cold, then again after it's warmed up good and see if anything changes.
    http://www.facebook.com/twinlakesjetskirepair

    '89 Kawi 650SX 42.4 GPS
    +3" stock pipe, ported ex. manifold, drilled waterbox, blueprinted pump, Ocean Pro ride plate

    '99 Yama GP1200 65U 61.8 GPS
    ported cylinders, matched cases, milled head, blueprinted pump, long ride plate

    '96 Seadoo HX 717 53.13 GPS
    light porting, massaged cases, lightened flywheel, port matched manifolds, Rossier pipe, stubby pump cone

  10. #20
    Frequent Poster cjburt's Avatar
    Join Date
    Mar 2005
    Location
    Enterprise, MS
    Posts
    156

    Re: SLT 780 wont run over 4000 rpm-Hitting limiter???

    Hi, I know this is an old post but I'm having the exact issue as explained earlier but I almost feel like it's not really a RPM limit issue. This one will hit 6900 rpms on the trailer. Just put it in the water and 4,000 RPM is all I get. I've got good compression, good spark, all gauges work perfect and no warnings. I installed new fuel pump, all new fuel lines, new plugs. It just acts as if it's in a limp mode. I've done the reset mentioned above. I also cleaned carbs. I just don't know what else to try. I don't have access to another cdi for a slt 780. I do have one for a 1050 I could swap someone if interested.
    Please help!

    Sent from my SAMSUNG-SM-G891A using Tapatalk

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0