pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» wallpapers

Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1

    Hard starting zxi 1100

    I have a 1998 zxi 1100. It has always been hard to start but once I get it started it runs all day with no problems. I solved the problem by installing a kit that lets me manually pump gas into the carbs before starting it. It seems like I have to pump a lot of gas into the carbs when the engine is cold before it starts. I've heard of others with the same problem who solved it with this kit. Is this common to zxi 1100's, or is there something else I should have done; e.g. rebuilt the carbs?

  2. #2
    PWCToday Guru Snowrider turned Jetskier's Avatar
    Join Date
    Jul 2006
    Location
    Dekalb IL
    Age
    31
    Posts
    346

    Re: Hard starting zxi 1100

    Check compression, If low a top end is needed

  3. #3
    PWCToday.com Is My Home Away From Home kawi66's Avatar
    Join Date
    Jan 2003
    Location
    kawiland
    Age
    48
    Posts
    2,430

    Re: Hard starting zxi 1100

    common on all the older triple kehin carb models.900 and 1100.

    you did the right thing,a primer. i do about ten a season on customers ski's.they start right up with two pumps on the primer.
    Never trust a fart past forty........


    1998 farthing big red lightweight x4....1100 kawi conversion
    1997 sheldon carbon lightweight zxi

  4. #4
    Frequent Poster
    Join Date
    Jul 2002
    Location
    SC
    Posts
    273

    Re: Hard starting zxi 1100

    Two pumps if the primer is primed. mine sometimes goes dry and then several pumps are required. if you pull the seat you can hear it when it squirts, as well as see the gas and bubbles in the line.
    \'96 1100ZXi

  5. #5

    Re: Hard starting zxi 1100

    Yes, the primer fixes the problem but I still can't figure out why all the gas drains from the carbs when the engine cools down and why I need a primer to start it. It shouldn't be that way! My Seadoo doesn't doo that.
    Maybe the pop off pressure is off.

  6. #6
    PWCToday.com Is My Home Away From Home JC545f's Avatar
    Join Date
    Jan 2002
    Location
    CA
    Age
    38
    Posts
    7,976

    Re: Hard starting zxi 1100

    Quote Originally Posted by nightshadow
    Yes, the primer fixes the problem but I still can't figure out why all the gas drains from the carbs when the engine cools down and why I need a primer to start it. It shouldn't be that way! My Seadoo doesn't doo that.
    Maybe the pop off pressure is off.
    your primer pump might be leaking air back into the fuel line. Did you install the primer line into the fuel "IN" line going to the carb, or the "OUT" line returning to the fuel.

  7. #7
    PWCToday.com Is My Home Away From Home kawi66's Avatar
    Join Date
    Jan 2003
    Location
    kawiland
    Age
    48
    Posts
    2,430

    Re: Hard starting zxi 1100

    your sea-doo has mikuni carbs. ALL the kehin carbs are like that,even the later model stxr/ultra ones.
    Never trust a fart past forty........


    1998 farthing big red lightweight x4....1100 kawi conversion
    1997 sheldon carbon lightweight zxi

  8. #8
    Frequent Poster
    Join Date
    Jul 2004
    Location
    Ks
    Age
    44
    Posts
    284

    Re: Hard starting zxi 1100

    I'v had both types of carbs on my ski, CDCV and CDKII, and they both needed a primer. I bought a set of 42mm Keihins and assume I'll have to prime them also.

  9. #9

    Re: Hard starting zxi 1100

    The in line. I guess I'll just have to live with using a primer judging by what everyone else is saying. I was hoping to be able to start the ski without using a primer but I guess that's not possible.

  10. #10
    PWCToday Newbie
    Join Date
    May 2009
    Location
    Miami
    Posts
    49

    Re: Hard starting zxi 1100

    Quote Originally Posted by Josh Chipps View Post
    your primer pump might be leaking air back into the fuel line. Did you install the primer line into the fuel "IN" line going to the carb, or the "OUT" line returning to the fuel.

    What's the proper line to T for the primmer kit the fuel IN" line or OUT" return line ?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0