pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Search:

Type: Posts; User: pol650; Keyword(s):

Search: Search took 0.02 seconds.

  1. Replies
    0
    Views
    277

    Oil pump problem

    I had my SL 650 engine rebuilt last spring due too low compression on the PTO piston. I've noticed that the piston compression was lower than the other two when I checked the compression after a...
  2. Replies
    8
    Views
    882

    Re: High rev at startup

    Oops!
  3. Replies
    8
    Views
    882

    Re: High rev at startup

    Here is an update on the situation. When I removed the auto****, I plugged the pulse line fitting with an automotive rubber cap and tighten it with a zip tie. The dealer found out that the cap was...
  4. Replies
    8
    Views
    882

    Re: High rev at startup

    Hi John,
    I've checked the spark plugs and they are black and a bit oily. If I had a lean condition, they should be white, if I'm right. After inspecting I found a loose wire (my Tiny Tach pick up...
  5. Replies
    8
    Views
    882

    Re: High rev at startup

    Hi John,
    First of all, I should mention that when I bought the ski, it was in its original state (auto****, single outlet fuel pump, etc.). Last saison, I removed the auto****, replaced the fuel...
  6. Replies
    8
    Views
    882

    High rev at startup

    I have my SL-650 engine rebuilt recently and a strange phenomena did append twice so far. The first time, I was in the garage checking the spark strength. The engine was cold and I hit the start...
Results 1 to 6 of 6
Powered by vBadvanced CMPS v4.2.0