Search Results - PWCToday
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Search:

Type: Posts; User: 7808; Keyword(s):

Search: Search took 0.00 seconds.

  1. Replies
    22
    Views
    1,501

    Re: 88 650sx only wants to go after a jump/get air

    562103
  2. Replies
    2
    Views
    327

    Re: js300 craps out after 10sec head getting hot

    what are the settings for the screws on a 86 300?
  3. Replies
    22
    Views
    1,501

    Re: 88 650sx only wants to go after a jump/get air

    so the seals leak at higher rpms and engine load? ill try to pressure test it again, last time my crap block off plates failed and were leaking
  4. Replies
    2
    Views
    327

    js300 craps out after 10sec head getting hot

    my sons 86 js300 has been fine until i touched it, it doesnt go for sht with me on it and im not a big dude so i thought maybe the high/low screws were off, mostly the high, so i tried to set them...
  5. Replies
    22
    Views
    1,501

    Re: 88 650sx only wants to go after a jump/get air

    yeah i found a spring roughly the diameter and cut it down in length until it was around 20psi pop off consistantly (thought that was the target pressure)

    honestly it doesnt seem to matter what...
  6. Replies
    22
    Views
    1,501

    Re: 88 650sx only wants to go after a jump/get air

    i ran the ski without the hood, wanted to make sure it wasent getting choked out some how, and you can tell if you give it throttle after idle for a min or parking it goes, then starts to stumble...
  7. Replies
    22
    Views
    1,501

    Re: 88 650sx only wants to go after a jump/get air

    i used the spring in the kit.

    i got the ski with a spring that had almost no hold back pressure, 1-2psi. i replaced it with a spring from the hard ware store cut down then it was at 19 pop off....
  8. Re: Flushing engine with motor not running possible?

    ive done it this way, seemed fine, only backs up into the motor through the exhaust as far as i know
  9. Replies
    22
    Views
    1,501

    Re: 88 650sx only wants to go after a jump/get air

    is there a way to test the external fuel pump? what jets should i be using?
  10. Replies
    22
    Views
    1,501

    Re: 88 650sx only wants to go after a jump/get air

    stock carb, stock intake, westcoast pipe. the ski had the carb rebuilt when i got it, and the pop off was set way low like opened at 1-2psi

    i put a new spring it and set it at 19psi

    then i...
  11. Replies
    22
    Views
    1,501

    Re: 88 650sx only wants to go after a jump/get air

    ive found confilcting info on what the pop off should be, i rebuilt the stock carb and tested pop off around 32psi, used a sbt rebuilt kit which im now told is not good? this ski ran good for a trip...
  12. Replies
    22
    Views
    1,501

    88 650sx only wants to go after a jump/get air

    Been trying to sort out a 88 650 I got that didn't want to go, always felt like it was only half throttle

    Then sometimes it goes fine

    Lately I've been able to reliably repeat this if it's...
  13. Replies
    13
    Views
    2,753

    Re: js300 and js440 both suck . slow wont plane etc

    this is what the plugs looked like after i ran it full speed then shut it right down https://photos.app.goo.gl/nhH3RBdrbHJKZp6N8
  14. Replies
    13
    Views
    2,753

    Re: js300 and js440 both suck . slow wont plane etc

    well if anyone has similar issues , i replaced the gasket on the 440 pictured above, and now it doesnt bubbles out around the welds and it actually planed got up to a decent speed. maybe almost full...
  15. Replies
    13
    Views
    2,753

    Re: js300 and js440 both suck . slow wont plane etc

    561196
  16. Replies
    13
    Views
    2,753

    Re: js300 and js440 both suck . slow wont plane etc

    Found a leak in the exhaust pipe , not sure if it's a aftermarket pipe 561194
  17. Replies
    13
    Views
    2,753

    Re: js300 and js440 both suck . slow wont plane etc

    And I can't find and loose exhaust or clamps on the 440
  18. Replies
    13
    Views
    2,753

    Re: js300 and js440 both suck . slow wont plane etc

    I'd be thrilled if either of these went close to 30

    "Old 650 superjets" are not cheap. Not anymore not around her not this season at least. People want $1200 for a working js300

    I leaned...
  19. Replies
    13
    Views
    2,753

    Re: js300 and js440 both suck . slow wont plane etc

    i think the gap your seeing may be shadow from the camera flash. ill take a look again but i can see what you might see as a large gap.

    ive had the motors out of both skis. ive went through alot...
  20. Replies
    13
    Views
    2,753

    js300 and js440 both suck . slow wont plane etc

    just looking for advice or ideas really, got a 86 js300 and 80 js440

    js300 - replaced the motor with one of unknown anything, 120-130 psi compression, oil mix stuff bypassed. all stock parts no...
  21. Replies
    0
    Views
    320

    updating fried 80' js440 ignition system?

    bought a 80' js440 today, really didnt want it, but it was $100 (85 psi on both cyl so prob needs a top end kit?) i dont know what happen to this thing, but there is alot of fried wiring. from the...
  22. Replies
    6
    Views
    779

    Re: overcharging for used pump housing?

    its a 96 gtx 780?

    i just found this one new for $215 http://www.parkeryamaha.com/browseproducts/SeaDoo-Pump-Housing-295500429.HTML

    im really not sure though my dad just called me and told me...
  23. Replies
    6
    Views
    779

    overcharging for used pump housing?

    my dad has his ski in at a place diagnosing a noise, they say a o ring was pinched when the pump housing was "rebuilt" previously and its is messed up now and they have a used one for $275 they will...
  24. Replies
    21
    Views
    2,499

    Re: 97' gtx weird not starting problem

    i knew i should have checked out the flywheel with a mirror or somthing when i had the starter out. usually when you buy a starter is comes with that bendix unit all areadly on ready to go right
  25. Replies
    21
    Views
    2,499

    Re: 97' gtx weird not starting problem

    ya i cleaned up the contact point of the brushes and i wanted to try it out but i was unsure if those teeth looked abnormally worn or not, the only other one ive worked on did not look like that but...
  26. Replies
    21
    Views
    2,499

    Re: 97' gtx weird not starting problem

    bump cause im kinda waiting to put this back in
  27. Replies
    21
    Views
    2,499

    Re: 97' gtx weird not starting problem

    brushes looked ok, the part they touch was kinda crappy so i scuffed it and wiped it off. i dont know if im gona re install it or just get a new one yet, does the teeth look too worn on this?
    ...
  28. Replies
    16
    Views
    2,046

    Re: Some good pics from Friday!

    wow those things look kinda fun, dont those ever land on you
  29. Replies
    21
    Views
    2,499

    Re: 97' gtx weird not starting problem

    today i hooked the starter up to a 10A battery charger and it spun nice and quiet, the "thing" went out then back in in about 2sec. it spins nice, do bad starters usually show signs when being bench...
  30. Replies
    21
    Views
    2,499

    Re: 97' gtx weird not starting problem

    cool thanks. im gona have to take the ebay sellers word for it then if the numbers dont match but it says its for my model.. i didnt see any sea doo p/n's
  31. Replies
    21
    Views
    2,499

    Re: 97' gtx weird not starting problem

    well, the starter was a real ******* to remove and the grou nd was still attached when i got the starter loose and half out and it (ground) was real tight with some kind off grey loctite or epoxy...
  32. Replies
    21
    Views
    2,499

    Re: 97' gtx weird not starting problem

    where is the solenoid and is there a way to test it?

    i thought bypassing the electronics going battery straight to starter would eleminate everything but the starter it self
  33. Replies
    21
    Views
    2,499

    Re: 97' gtx weird not starting problem

    ok from my searching its looking like it probly is the starter, i already pulled it, is there a way to verfiy the starter is bad? when it was still in i did jump the lugs on the relay and it did...
  34. Replies
    21
    Views
    2,499

    97' gtx weird not starting problem

    i have a 97 gtx and the other day it died on the water, now it just sounds like it wants to turn over but cant like the starter doesnt have enough power or is jammed, battery is good. it clicks twice...
Results 1 to 34 of 34
Powered by vBadvanced CMPS v4.2.0