Yamaha vx110 Deluxe low speed high rpm - Blogs - PWCToday
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

View RSS Feed

perryalex27

Yamaha vx110 Deluxe low speed high rpm

Rate this Entry
Hi everyone, I just bought a 2008 Yamaha Vx Deluxe with 35 hours on it and I have had some issues with it. I bought it from the original owner that barely used it. He didn't take care of it too well but he had basic servicing done each season at a dealer. I met the seller at the dealer and brought it home right from there. It had paperwork with it that stated that an oil change was done, new plugs were installed, and it was flushed on the hose. I was going to water test it but after seeing the paperwork from the dealer I didn't think that it was necessary. When I brought it home and started it on the hose everything seemed fine so I took it to the lake and the pisser wasn't working. I let it idle for a little and the engine was cool and exhaust was also decently cool so I rode it a little checking on it periodically. Everything was fine and I didn't have any warnings. I have since cleared it out and found seaweed in the system. When I was riding I noticed that I was only going about 42mph at full rpm. I checked the oil and it was well over the F line so I drained some out and changed the air filter(as it had some oil on it). I went back out on the water and and I didn't notice a difference in performance. So, I took the impeller housing off and there was barely a gap and the impeller was in decent shape(a few minor dings but nothing that would cause a 10mph decrease). I then reinstalled the jet pump and went back to the water and it only hit 42mph again. I had 2 full size adults on it and it still went 42mph. I would get full rpm at about 3/4 throttle. Iím not sure if this is normal or not. I even used a gps to make sure that the speedometer was correct and it was. I don't know what else to look at other than maybe the plugs. They could have been fouled from the excess oil but wouldn't it run poorly? Would it reach 8k rpm if the plugs were fouled? There are some scratches on the bottom of the hull that I still need to fix but I can't imagine that they would cause a 10mph speed decrease. Also, the engine vibrates a little when idling. This is my first 4 stroke ski so I'm not sure if it should be running completely smooth or a little rough.
Tags: None Add / Edit Tags
Categories
Uncategorized

Comments

Powered by vBadvanced CMPS v4.2.0