pxctoday

View RSS Feed

Recent Blogs Posts

  1. 2009 RXT 215's

    I have a set of PWC's one has 91 and one has 81 hours. They fire up fine and sound fine on land. I put them in the water for the first time last weekend and both were having the same issue. Very sluggish off the start and topped out at 50 mph and about 6200 rpm's. They both acted like they wanted to give you more with catching a tiny bit of power for a couple seconds and shoot up to about 58 then back down. I have changed the plugs in both now but have not tested them in the water again. Are ...
    Categories
    Uncategorized
  2. Fuse on 2016 Kawasaki Super Jet

    Could someone please tell me where the fuse box is located on a 2016 Kawasaki Super Jet?
    Thanks
    Categories
    Uncategorized
  3. 2002 gtx 4 tec

    Need help please, bought a couple of seadoos
    a few weeks back, took the 2002 gtx to lake
    ran awesome for about an hr then all of a sudden it lost piwer in the throttle, went into limp mode, changed plugs out
    went back Sunday and the same thing, anyone that can help would be appreciated, by the time I got in there was no code showing, so Thursday took it to the lake and went into limp mode
    in only 10 min of riding, I check for code and it said P1681 which is communication ...
    Categories
    Uncategorized
  4. Dịch vụ s*a tivi tại nh* giá rẻ nhanh chóng

    Tivi nh* bạn đang bị hư ? Tivi nh* bạn đang gặp trục trặc cần khắc phục chóng vánh, bảo h*nh ch*nh hãng với chi ph* kiệm ước nhất, an to*n v* thu*n tiện nhất? Hãy đến với dịch vụ s*a tivi tại nh* của Điện Máy Thiên Hòa chúng tôi.
    Trung Tâm tu chỉnh Bảo H*nh Điện Máy Thiên Ho* được th*nh l*p từ năm 2001 với hội sở tại đường CMT8 TPHCM v* chi nhánh bảo h*nh trải d*i khắp tphcm v* các ...
    Categories
    Uncategorized
  5. 1995 Kawasaki sts 750 not running right

    Hi guys my 1995 Kawasaki sts 750 will start right up but when you ride it for 20 or so minutes it goes into a limp mode. I've spent a lot of money at 2 different shops trying to get it fixed but no luck.
    It has new gaskets, fresh carb kit , fresh lines
    Water is coming out of the pisser just fine, the compression is fine as well... please help.... I do believe it's the stator but I need help finding the solution
Page 1 of 129 1231151101 ... LastLast