PWCToday - Entries for April 2019 - Blogs
pxctoday

View RSS Feed

Recent Blogs Posts

  1. New to the scene, 650sx trouble shooting

    Never had a ski but have takin a few rides on them. Ive already learned a bunch reading from PWC Today and appreciate all the info. I just picked up a 1990 650sx. Came stock except for dual cooling. So far I added extended ride plate, installed lanyard switch, finger throttle, grips, bilge and switch, all new hydro turf not installed yet except on hood, blue water line tube, green gas tube and paint.

    So I started it this weekend, second time starting (didnt have the hose connection ...

    Updated 04-30-2019 at 02:22 AM by Jcstomp

    Categories
    Uncategorized
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20190406_210401.jpg 
Views:	21 
Size:	3.95 MB 
ID:	548580   Click image for larger version. 

Name:	20190428_185901.jpg 
Views:	20 
Size:	5.37 MB 
ID:	548581   Click image for larger version. 

Name:	20190428_185918.jpg 
Views:	22 
Size:	4.68 MB 
ID:	548582  
  2. Hydrodoo jetting need help

    Hi everybody! Im new here and from belgium. Can someone help me with my hydrodoo ? He hesitate a little bit from iddle to 1/4. After he goes right to the max! My settings : stock head and exhaust, 89,5 prox piston with new bored cilinder. Stock 46i carbs, carbon tech reeds. Carb setting : 2,5N/S 65gr spring, Ls 95 1 1/2 turn out, HS 167 1/2 out. Its a old race ski, i bougjt it last summer for cheap and i seized a piston because the base gasket was out!!!

    thans

    cedric
    Categories
    Uncategorized
  3. 08 wave runner cluster

    My cluster is toast.How do I sync a new unit?
    Categories
    Uncategorized
  4. 2001 GTX DI 951 Motor blowing 15amp INJ FUSE

    Quote Originally Posted by Lilmac View Post
    Can anyone help me, I have a 951 DI motor blowing the INJ FUSE 15 amp intermittenly. It seems to do it when you try and go full speed? If you stay around 50mph it doesn't seem to blow? I have ohmed stator to ground and between windings, ignition coils, fuel injectors, rave solenoid and turned it on 30 times using 2 amp fuse directly to the battery and it clicks on and off fine. Any help would be appreciated. Thanks Lilmac
    Categories
    Uncategorized
  5. 1996 787 GTX will not run right

    Bought a used 1996 GTX 787 a couple years ago and am having trouble getting it to run smooth. I ran it for most of the summer when I purchased it and it ran real good, towards fall (after about 10 -12 rides) my kids told me it started to bog a bit getting out of the hole but once it cleaned it self out/warmed up the bog was gone. I did some research online and realized it still had grey gas lines so during the winter I replaced all the fuel lines and rebuilt the carbs with carb kits I purchased ...
    Categories
    Uncategorized